Page 1 of 1

Changed icons convert to black squares

PostPosted: Tue Mar 04, 2003 6:36 pm
by naboJAB
looking for an answer to the one imperfection in this almost perfect tool.
Changing icons work fine in setup window but in use those changed ones show up as black squares (default & custom tried)
Using W2k
tried tweakui icon repair

PostPosted: Wed Mar 05, 2003 7:25 am
by nabocorp

I sometimes saw this problem when the machine is running low on memory but it is always just temporary. In any case it is very hard to reproduce but as soon as I'll have a solution I'll update My Folders.

Did you notice that hihg-memory condition and the fact that it is only temporary?


PostPosted: Wed Mar 05, 2003 11:32 am
by Guest
yes I know the thing you mean - would get this in W95 a few years ago
but I never experience this problem now.
This (w2k) system has 256meg memory and system can run happily for weeks without re-boot but when I saw this I re-booted immediately to no effect.
It is consistant - I've *never* seen an alternative icon show up correctly (except in Setup Window where its perfect).

At the moment for instance Total phys=261000kb Free=84000kb


PostPosted: Wed Mar 05, 2003 11:46 am
by naboJAB
I've just tried installing on a freshly installed W2000 PC and it's showing exactly same symptoms on it too.

PostPosted: Wed Mar 05, 2003 3:59 pm
by nabocorp
Sorry I never saw this issue happening so it will be very hard to fix! The one temporary thing I was talking about is not the whole icon going black but only the part that is supposed to be transparent.

Maybe you can check if you are using the latest video drivers for your card. If this does not solve the issue then the bug prevents you from using My Folders and I probably will not be able to fix this. So if you are a registered user then simply get in touch by mail with and I'll give you your money back.


PostPosted: Wed Mar 05, 2003 6:09 pm
by naboJAB
it works ok with standard folder icon so no probs functionaly - but this product *is* better than all the rest I've tried (even though their icons work ok!)
It would be an *enormous* shame to give up on this - it really is *such* a nice simple solution.
It seems to be a W2000 issue - and not something major - as the My Folders Setup screen handles it OK! - what's the significant difference between that Setup display and one where My Folders GUI is called ?!
If you want to trial any beta changes, send me and I'll try out.
What kind of app is it - C, VB, etc ?

PostPosted: Wed Mar 05, 2003 11:07 pm
by nabocorp
The way icons are displayed in the Setup dialog and in the menu is completly different and that explains why it is working in one case and not the other...

To display the icons in the menu I have to convert icons to bitmaps and this seems to fail on the systems you tried (although I know people running My Folders on W2K). The standard folder icon is directly embedded into My Folders as a bitmap so no conversion is required...

My machine at work will soon be upgraded from NT4 to W2K. With little chance I might reproduce the bug :-) The app is written in C++ (as all my programs are).

Did you try the video card driver update?


PS: which other software like this one did you try? The only one I know is Access Folders which is way too expensive (that's why I made My Folders BTW :-)

PostPosted: Thu Mar 06, 2003 12:08 am
by naboJAB
integrated mobo video - AOPEN MX3/Intel - updated a few months ago - I'm sure it isn't that. I download a *lot* of software and (touch wood) never experienced icon probs.
I've tried
- PlacesBar (MaDdoG Software) - nice idea but W2000 fileopen PlaceBar is hugely ugly - to the point of impractibility.
- Quick Folders - can't sort
- RunIt - handy for common files/folders etc but no integration with open

There's quite a few web sites focusing on this now - e.g.

PostPosted: Thu Mar 06, 2003 12:13 am
by naboJAB
is the excellent Cam2PC written in C++ as well ?
icons are fine in it.

PostPosted: Thu Mar 06, 2003 7:55 am
by nabocorp
Yes cam2pc is C++ too. But My Folders is the only software doing icons to bitmaps conversion on the fly.


Same Problem

PostPosted: Thu Oct 23, 2003 4:55 am
by Guest
For the record, I have the same problem.

Win2k Service Pack 2
ATI All in Wonder Pro PCI (Rage Pro Chipset)

The problem continues if I switch output to be from a Voodoo3 AGP card. So I'm thinking its an OS issue not a video card one.